
UbuntuBuzz 
Magazine Bundle

A Monthly Bundle from 
UbuntuBuzz.com

ISSUE #6
September 2015

GNOME Custom Guide
Tweak GNOME Desktop [39]

Cinnamon Custom Guide
Tweak Cinnamon Desktop [45]

MATE Custom Guide
Tweak MATE Desktop [51]

Beginner XFCE Guide
How To Use XFCE for Daily Usage [3]

Beginner Unity Guide 
How To Use Ubuntu Official User Interface [22]

Qpdfview, Multitab PDF Reader
Get A Real “Foxit Reader” in Linux [36]



Table of Contents

BEGINNER XFCE DESKTOP USAGE GUIDE..........................................................................................3

BEGINNER LXDE DESKTOP USAGE GUIDE.........................................................................................7

BEGINNER LXQT DESKTOP USAGE GUIDE.......................................................................................11

BEGINNER BLANKON MANOKWARI DESKTOP USAGE GUIDE....................................................15

HOW TO DISABLE CINNAMON RECENT FILES IN MENU...............................................................20

BEGINNER UBUNTU UNITY DESKTOP USAGE GUIDE....................................................................22

BEGINNER CINNAMON DESKTOP USAGE GUIDE...........................................................................28

HOW TO DISABLE KDE RECENT DOCUMENTS IN MENU..............................................................34

HOW TO INSTALL SYSTEMBACK IN UBUNTU 15.04.......................................................................35

QPDFVIEW, PDF MULTITABBING VIEWER FOR LINUX...................................................................36

HOW TO INSTALL UNITY TWEAK TOOL ON UBUNTU 15.04........................................................38

BEGINNER GNOME DESKTOP CUSTOMIZATION GUIDE...............................................................39

BEGINNER CINNAMON DESKTOP CUSTOMIZATION GUIDE........................................................45

BEGINNER MATE DESKTOP CUSTOMIZATION GUIDE...................................................................51

DISABLE UBUNTU UPDATE NOTIFICATION.....................................................................................58

2



BEGINNER XFCE DESKTOP USAGE GUIDE
This guide will explain you how to use XFCE desktop for daily usage. After our fourth KDE 
guide, now it is our fifth about XFCE. XFCE is an user friendly desktop with wide ability for 
customization. XFCE is . XFCE allows users to use the desktop just by clicking. XFCE is 
famous of being used as default desktop on Xubuntu. This guide will not explain any of 
XFCE technical or historical side. This article is written for those who never use Linux or 
XFCE before. 

Anatomy

A default XFCE desktop consists of several parts. 

1. Menu. 
2. Applet (in this example, Desktop Switcher). 
3. Taskbar. 
4. System Tray.
5. Date & Time.
6. Desktop Shortcuts.

Concepts

For you Windows users or anyone never seen XFCE before, there are some concepts to help 
you understand XFCE before you use it. 

• XFCE desktop has two main components, panel and applet. It is different with 
Windows 

• XFCE desktop has different layout with Windows, while XFCE place its panel on top. 
• XFCE has taskbar and tray on the menu panel, same with Windows. 
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• XFCE allows desktop shortcut like Windows or Mac OS X, different with GNOME. 
• XFCE has some KDE concepts in one side, and some GNOME concepts in other side. 

Launch Apps

To launch an app in XFCE, open menu and search. Or open menu and click. 

Create Shortcut
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To create a desktop shortcut, similar with Windows and KDE, open menu > right-click on one 
app > Add to Desktop.

Alt+Tab

To switch between running apps in XFCE, same with another desktop, press Alt+Tab.

Multiple Desktop

Actually, XFCE default doesn't have workspace switcher yet. But you may add it yourself by 
adding a Switcher applet. In this example, I place my switcher on the left of menu. I have 4 
desktops here (represented in 4 boxes above).

Work with Workspaces

To wrk with workspace, simple 
place your app on its own 
workspace. For example, place 
Firefox on desktop 1, Libreoffice 
in desktop 2, and so on. To move 
an app window, simple use the 
taskbar. Right click on one app (i.e. 
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File Manager like picture above) > select Move to Another Workspace > select number.

System Tray

XFCE has a system tray similar to GNOME's one. From left to right: network manager, 
battery indicatr (for laptops), sound indicator, and calendar.

Reference

http://docs.xubuntu.org/1404/guide-desktop.html 
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BEGINNER LXDE DESKTOP USAGE GUIDE
This guide will explain you how to use LXDE desktop for daily usage. After our fifth XFCE 
guide, now it is our sixth about LXDE. LXDE is a lightweight desktop from the beginning to 
help us revive old computers. Of course, if you run LXDE on better computers, it will run 
faster. LXDE gives you pont and click desktop experience. LXDE is famous of being used as 
default desktop on Lubuntu. This guide will not explain any of LXDE technical or historical 
side. This article is written for those who never use Linux or LXDE before. I use LXDE on 
Lubuntu 14.04.

Anatomy

A basic LXDE desktop should look like this. And its appearances consists of several parts:

1. Menu. 
2. Shortcut icons. 
3. Workspace switcher. 
4. Taskbar. 
5. System tray. 
6. Desktop shortcut. 

Concepts

1. LXDE has traditional desktop layout similar to Windows. 
2. LXDE has bottom menu, taskbar, and tray on the taskbar, similar to Windows.
3. LXDE has no animation effect.
4. LXDE has very minimalistic features.

7



Launch Apps

To launch an app in LXDE, click on the menu. It is similar with KDE or Windows menu. But no 
search here.

Create Shortcut

To create a desktop shortcut, find one app in menu > right-click > Add to desktop. Basically, 
it is same with KDE or Windows.

Alt+Tab

To switch between running apps, use Alt+Tab.

Multiple Desktop
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LXDE has multiple desktop since the beginning. In Lubuntu 14.04, you have two desktop by 
default. See the rectangles icon on the bottom-left of your screen. Of course, you may add 
it if you want. You can switch desktop by clicking on it.

Work with Workspaces

Like another desktop environments, you can move a window to another workspace 
(desktop) and switch between workspaces easily to improve your multitasking experience.
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System Tray

LXDE shares similar tray with KDE or Windows. From left to right, LXDE has sound indicator, 
keyboard indicator (you may change your layout here), battery indicator, network manager, 
and calendar. On the most right of panel, LXDE has logout button contains shut down and 
restart.

Reference

http://wiki.lxde.org/en/Main_Page 
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BEGINNER LXQT DESKTOP USAGE GUIDE
LXQt is a newcomer desktop environment for Linux. It is a lightweight desktop with modern 
look. LXQt is suitable for old computers, same with LXDE. LXQt is actually LXDE + Qt (LXDE 
but reconstructed with Qt Framework). LXQt was born from merger between LXDE and 
Razor-Qt project. It is also similar with Windows in which they have same layout. But LXQt is 
for those who like LXDE simplicity but prefer Qt against GTK. Note for you, KDE is created 
from Qt and LXDE is created from GTK. Using LXQt is similar to using LXDE with KDE look. 
This article is for beginner Linux user especially those who never used LXQt before. I use 
LXQt 0.7.0 on Manjaro Ascella for this article.

Anatomy

1. Menu. 
2. Workspace switcher. 
3. Shortcut icons on panel. 
4. Taskbar. 
5. System tray. 
6. Shortcut icons on desktop. 
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Concepts

• LXQt has traditional desktop layout, same with Windows. You see the menu, taskbar, 
and system tray are on the same bottom panel. 

• LXQt has minimalistic effects. It is a consequence to be lightweight. 
• LXQt is basically a LXDE desktop with KDE look.

Launch Apps

To launch an app, click menu > select category > click app. LXQt has no search bar.

Create Shortcut
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To create an application shortcut, select one app from menu > drag into taskbar > drop it. 
You must drop it on the shortcuts group. This is the easiest way in LXQt.

Alt+Tab

To switch between running apps, press Alt+Tab.

Multiple Desktop

LXQt has multiple desktop like another Linux desktop. You will see 4 
boxes beside the menu button on the taskbar panel. They are your 
workspaces. To switch between those workspaces, just click on the box 
you want.
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Work with Workspaces

Same with another desktop, you can move a window to another 
workspace. To do that, right-click on the app on the taskbar > To 
Desktop > select one number.
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System Tray

LXQt system tray is similar with Windows' one, and is basically same with LXDE's one. From 
left to right: 

• Network manager. You connect to a network by this. 
• Device indicator. You mount or unmount removable media (DVD, USB Stick, HDD) by 

this. 
• Time and calendar. Your clock and calendar.

Notes

• Qt is a set of programming libraries that used to create KDE. 
• GTK is a set of programming libraries, just like Qt, that used to create GNOME, XFCE, 

and LXDE. 

References

• https://wiki.archlinux.org/index.php/LXQt   
• https://wiki.gentoo.org/wiki/LXQt   
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BEGINNER BLANKON MANOKWARI DESKTOP USAGE GUIDE
Manokwari is a desktop environment from Blankon Linux. Manokwari is a lightweight 
desktop with unique user interface. It is suitable for old computers. This article will tell you 
how to use Manokwari for daily purpose. I use Blankon 9 Suroboyo for this article.

Anatomy

1. Menu. 
2. Taskbar. 
3. Desktop shortcut area. 
4. System tray.

Concepts

• Manokwari has GNOME 3 basic layout. You find only top panel (contains menu, 
taskbar, and system tray). 

• Manokwari has its own desktop shortcut system, very different with Windows. 
• Manokwari has its own menu, very different with Windows even with GNOME 3 itself.

Launch Apps
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To launch an app on Manokwari, open menu > select one category > select one app. 
Manokwari has no search bar. 

Create Shortcut

To create a shortcut, open menu > select one category > right-click one app > Add to 
Desktop. A new shortcut will appear on the bottom special panel. That is a panel for 
shortcuts. That is Manokwari desktop shortcut system.

 

Delete Shortcut

To delete a shortcut in Manokwari, you can't 
simply just right-click > Delete it. you should drag 
one icon into a trash icon on top of it. 
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Using Taskbar

Manokwari is an unique desktop. Manokwari 
taskbar, if you hover your cursor over a running 
app, a new black horizontal panel will appear. 
That black panel is tooltip. It is because 
Manokwari taskbar shows only the icons. The 
black panel helps you to distinguish between 
icons.

Alt+Tab

To switch between running apps, press Alt+Tab. 

Multiple Desktop
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Manokwari has multiple desktop since the beginning. You have 4 desktops by default. To 
switch between desktop, use workspace switcher on the top-right of screen.

Work With Workspace

To move a window into another workspace, right-click on its icon on the taskbar > Move to 
Another Workspace > select number. 

System Tray
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Manokwari and GNOME have similar system tray. It consists of some items. From left to 
right:

1. Keyboard input controller (SCIM). Manokwari has it to switch between Indonesian 
regional input systems. 

2. Network manager. You connect to a network by this. 
3. Sound indicator. You control sound volume by this. 
4. Battery indicator. If you are using laptop, it will represent your battery power. 
5. Time and calendar. 
6. Workspace switcher. If you want to switch between desktops.
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HOW TO DISABLE CINNAMON RECENT FILES IN MENU
If you find Recent Files in Cinnamon menu is annoying, then disable it. Unfortunately, 
Cinnamon System Settings has no option for this tweak yet. So you must do that manually. I 
use Cinnamon 2.2.13 on Linux Mint 17. This tweak is applicable to Cinnamon in another 
Linux distro. 

Temporarily

Open menu > Recent Files > press Clear list. If you open another files in Cinnamon, this 
section will be filled again.

Permanently

To disable this Recent Files permanently, we need to set the recently-used.xbel file to 
immutable. It means no one can edit this file, create link from, delete, add a text, except a 
root remove the immutable attribute from this file. Perform this command:

sudo chattr +i ~/.local/share/recently-used.xbel  

chattr is change attribute command. Option +i plus immutable) gives immutable attribute 
to the file. That ~/.local/share/recently-used.xbel is the file where any recent files recorder 
for Cinnamon menu. Remember that you can't perform chattr command in a livecd (RAM 
filesystem).

To revert it back someday, as a root, perform a reverse command:

sudo chattr -i ~/.local/share/recently-used.xbel  
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Reference

http://askubuntu.com/questions/540661/how-do-i-disable-the-recent-files-feature-in-the-
cinnamon-desktop-environment 
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BEGINNER UBUNTU UNITY DESKTOP USAGE GUIDE
Unity is default desktop environment for Ubuntu. It has different appearance and user 
experience compared to another desktop environment. It has few unique features such as 
HUD and Launcher. It has also a full screen menu. It makes Ubuntu distinguishable among 
another Linux distro. This guide will help you understand the basics of Unity for daily usage. 
This guide uses Unity 7.3.2 on Ubuntu 15.04 as a basic and it's applicable to another version 
too. 

Anatomy

 

1. Menu button.
2. Global menu area. 
3. Launcher panel.
4. Desktop area. 
5. System tray.

Concepts

 
1. Unity is basically a GNOME 3 desktop. Unity is a shell for GNOME 3, replacing GNOME 

Shell itself. As a result, Unity brings its own components, but brings also many 
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GNOME components (e.g. Nautilus). Unity and GNOME share few similarities.
2. Unity is unique by its visual appearance and its user experience. Unity is like a mix of 

Mac OS X interface (by top panel and global menu) and Android Launcher (by wide 
screen menu). The most noticeable part of Unity is left vertical panel called Launcher. 
Launcher position is permanent.

3. Unity has Dash. It is the application menu. In Android, you call it Android Launcher. 
Yes, Unity was designed for touch screen platform.

4. Unity has HUD. A feature that never existed in every Linux desktop environment 
before. HUD allows you to use every menu in any GUI application by typing a few 
letters. HUD makes Unity different with all other Linux desktop environments.

5. Unity has global menu. We will find it on Mac OS X, when any GUI application menu 
will appear not in its own window but on Unity top panel. 

6. Unity has Lens. A Lens is a category in Unity Dash.
7. Unity doesn't support desktop shortcut (like Windows) by default. Unity has its own 

shortcut system, that is the vertical Launcher panel.
8. Unity places min-max-close buttons on the left, in contrary with usual desktop 

(Windows, KDE, XFCE) on the right. 
9. Unity opens the menu by a single win key (super key, windows key on your keyboard) 

just like Windows. It was also default behavior in GNOME.
10. Unity Dash will show you many information event if you don't need it. For example, 

when you browse for apps, you will see the installed and the ready to install list of 
applications. Don't panic, it is just a marketing strategy of Unity.

Launch Application

To launch application, open Dash (Unity Menu) by pressing win key > type the name > click 
on the icon. To browse between all installed apps, open Dash > click on 'A' Lens (number two 
from left) > click Filter Results (top-right) > click Local Apps from Sources entry (bottom-
right).
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Create Shortcut

 
To create a desktop shortcut, first open an app > right-click on 
its icon on Launcher > Lock to Launcher. This icon will 
permanently be here. I use Disk Usage Analyzer app in this 
example. 

Global Menu

To use Unity global menu, just open an app. If the app has 
menu (usually consists from File – Edit – View – Insert ...), then 
the menu will appear not in its own window but on Unity top 
panel. It is a centralized concept so it will helpful when you 
open many apps in a time. You access the same position, for 
every app menu. 

Work with HUD

To activate hud, press Alt key. HUD is quicker 
way to access all menu on every application. 
Every menu entry (e.g. menu Insert > Header) 
in one application window, HUD can read it. 
Then you can run it from HUD without 
clicking. In summary, with HUD, you save your 
clicks by using search instead. For example, I 
show you GIMP, Nautilus, Libreoffice, and 
Firefox common usages of HUD.

GIMP Blur: press Alt > type blur. 
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Nautilus Show Hidden Files: press Alt > type hidd.

Firefox Clear Recent History: press Alt > type history > select Clear Recent History.

Libreoffice Bibliography Entry: press Alt > type bibl.

Note: HUD usage is very useful when you are using GIMP or another graphic design 
programs. HUD will help you to work quicker. Examples above are just examples. You may 
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extend them to suit your needs. 

Alt+Tab

To switch between running apps, press Alt+Tab. It is the same 
way with another desktop environments. Special bonus for 
Unity, when performing Alt+Tab, press apostrophe button 
(beside of 1 button) to see a window preview on the fly. 

Spread Window

To see overview of all running apps, instead of Alt+Tab, press Win+W. It is similar with 
GNOME spread window. Here, hover your cursor to one window then you will see its titlebar 
with app name and close button. It is also a convenient way to close a window by seeing its 
preview. 

Multiple Desktop

Unity supports multiple desktop. But it is disabled by default. 
To enable it, open Unity System Settings > Appearance > 
Behavior > check Enable workspaces. Unity has 4 workspaces 
by default. A new icon will appear on your vertical Launcher. It 
is your workspace switcher. To use multiple desktop, press 
Win+S. 

Work with Workspaces

To work with workspace, right-click on window titlebar > Move to Another Workspace > 
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select. The easier way is by Win+S and drag one window to another workspace.
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System Tray

Unity system tray consists of several items. From left to right:

1. Network manager. 
2. Keyboard indicator. You choose keyboard layout here. E.g. change it into Japanese.
3. Battery indicator. It will appear if you are using laptop. 
4. Sound indicator. You set volume or control your audio player here. 
5. Time and calendar. 
6. Power.

Reference

http://askubuntu.com/questions/333237/difference-between-unity-and-gnome 
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BEGINNER CINNAMON DESKTOP USAGE GUIDE
Cinnamon is an official desktop environment for Linux Mint. Cinnamon is created by Linux 
Mint developers. Cinnamon is a great desktop when it brings traditional concepts but 
modern facilities. Any ex. Windows user will quickly learn Cinnamon (compared to another 
desktop) because it is very similar. Cinnamon, is simple by interface but is very flexible by its 
extensions. This guide will introduce you basically how to use Cinnamon for general daily 
usage. This won't tell you any technical or historical side of Cinnamon. This Cinnamon is our 
seventh guide after our sixth LXDE. I use Cinnamon 2.2.13 on Linux Mint 17 here.

Anatomy

1. Menu.
2. Shortcut icons on panel.
3. Taskbar.
4. System tray.
5. Shortcut icons on desktop.

Concepts

• Cinnamon has traditional desktop layout, same with Windows. You find the position 
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of menu, taskbar, tray, are same with Windows.
• Cinnamon allows desktop shortcuts, same with windows.
• Cinnamon has multiple desktop concepts.
• Cinnamon desktop consists of two components: panel and applet. It is basically same 

with KDE (panel and widget).

Launch Apps

Cinnamon has exactly same methods to open applications with Windows. It is because they 
share the same traditional concepts. Basically, you have 4 options.

1. Press Win key > select an app.
2. Press Win key > search > select.
3. Double-click on the app icon on the desktop.
4. Click on the app icon on the panel.

The most comfortable method for an ex. Windows user usually is number 3. Cinnamon does 
it well for you now in Linux.

Alt+Tab
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To switch between running apps, press Alt+Tab.

Spread Windows
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Cinnamon has also apps overview like in GNOME or KDE. Press Ctrl+Alt+Down.

Multiple Desktop

Cinnamon has standard multiple desktop features and more awesome 
concepts to help you work more efficiently with workspaces. Cinnamon 
has a bottom-right icon on the panel to switch between workspaces. 
Beside it, Cinnamon has also workspaces overview (like Desktop Grid in 
KDE). You may access the switcher by click on the bottom-right button 
on the panel. You may use shortcut key Ctrl+Alt+Up to show 
workspaces overview. 

As the concepts between Linux desktop environments are basically 
same, you may add or remove desktop number. In Cinnamon, after you 
show the overview (Ctrl+Alt+Up), you may click plus button on the left 
side of overview.

Work with Workspaces
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Cinnamon's concepts for switching between workspaces are same 
with another desktop. Right-click on an app in task bar > Move to 
right workspace. Or, right-click on an app titlebar > Move to right 
workspace. This will automatically add a new workspace and move 
this window into that workspace. It is same with MATE, GNOME, KDE, 
or any other Linux desktops. And similar with KDE Desktop Grid, you 
may drag and drop a window from one workspace to another to 
move it when you perform workspaces overview (Ctrl+Alt+Up).

Tiling Window

Cinnamon --as a Linux desktop environment-- inherits old UNIX window manager concepts 
named tiling window. You probably know this concept in 
Windows, when you resize two different windows side by side 
(probably two Windows Explorers to ease copying process). In 
Cinnamon, you can do it easily by Ctrl+Win+Arrow Key. Up or 
down arrow key will resize and fit a focused window into the 
top or bottom area of the screen. Left or right arrow will 
resize and fit it into the left or right. More, if you drag a 
window into one of screen corners, Cinnamon will automatically resize and fit it on that 
position. It is similar with Windows 7 tiling system.
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System Tray

Cinnamon has a complete system tray. From left to right as shown on picture above:

1. Notification area. Any notification will be shown here.
2. User indicator. You can access your own user, manage it, and logout here.
3. Device indicator. You mount or eject drive here.
4. Network manager. You connect to a network (WLAN, LAN, Mobile Broadband, VPN) 

here.
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5. Sound indicator. Your volume control and audio player tray are here.
6. Battery indicator. If you are using laptop, it will appear.
7. Time and date indicator.
8. Workspace switcher. Your desktop switcher.

Reference

http://cinnamon.linuxmint.com 
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HOW TO DISABLE KDE RECENT DOCUMENTS IN MENU
If you are using KDE, and find Recently Used section in your menu, you probably feel it is 
annoying. Especially for your privacy. So how to disable it? There are two methods, 
temporarily and permanently. I use KDE 4.10.3 (Ubuntu 12.04) here and you may use this 
article until KDE 5.

Temporarily

Open KDE Menu > Recently Used > right-click > Clear Recent Documents. Remember, any 
file you open later, will fill this Recent section again.

Permanently

Do this command:

chmod u-w ~/.kde/share/apps/RecentDocuments/  

This command means user minus write (forbid user to write) for KDE RecentDocuments 
directory. If you forbid any writing attemp into RecentDocuments, automatically it will be 
disabled in KDE Menu. This is applicable in KDE for Ubuntu. If you are using another distro 
(e.g. openSUSE), maybe you must use .kde4 instead of .kde directory.

Reference

http://www.sqtl.co.uk/blog-article/items/disabling-kde4-recent-documents-menu.html 
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HOW TO INSTALL SYSTEMBACK IN UBUNTU 15.04
Systemback is a remastering and system restore tool for Linux. With Systemback, you get 
again what you lost from Remastersys (abandoned) or Windows System Restore. 
Systemback keeps your configurations, software installations, themes, and the whole 
system so it is suitable to make a Linux remaster. You can make a whole backup of your 
system periodically then revert back into previous state of your Linux system. For Ubuntu 
14.04, 15.04 and 15.10, there is a PPA for Systemback. Thanks to Kedek for providing this 
PPA. 

Using Terminal

sudo apt-add-repository --yes ppa:nemh/systemback  
sudo apt-get update  
sudo apt-get install systemback  

Those commands will add a new repository named ppa:nemh/systemback into your Ubuntu 
system, then download the repository indexes, and then install Systemback. Option --yes 
assumes you will always answer yes for every question.

Using Synaptic GUI

 

Using GUI is often much more easier. Open 
your Synaptic first.

1. Open menu Settings > Repositories > 
Other Software > press Add. 

2. Write ppa:nemh/systemback > press 
Add Source. 

3. Press Reload button.
4. Search for systemback.
5. Click systemback from search result > Mark for Installation > Apply. 
6. Wait until finished.

Reference

• https://launchpad.net/~nemh   
• http://sourceforge.net/projects/systemback/   
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QPDFVIEW, PDF MULTITABBING VIEWER FOR LINUX
Are you looking for multitab PDF viewer in Linux? Probably you want an alternative for 
Foxit Reader. Then use Qpdfview. It supports multitabbing. Also, it supports zooming, 
continuous view, fullscreen, properties viewing, sidebar, and so on. Fortunately, Qpdfview 
is available on Ubuntu official repository and many other distro repositories. Personally, I've 
used Qpdfview on my KDE as default PDF viewer because I always open many PDF files at 
once. I hope Qpdfview is useful for you too. 

Install on Ubuntu

sudo apt-get install qpdfview  

If you dislike to command, use Ubuntu Software Center instead.

Install on Another Linux Distro

If you don't use Ubuntu (Debian, Linux Mint, and their family), choose one of these 
methods.
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1. Install on Fedora

sudo yum install qpdfview  
sudo dnf install qpdfview  

Use dnf if you are using Fedora 22 and above. Use yum if you are using Fedora before 
version 22.

2. Install on openSUSE

sudo zypper qpdfview  
  

3. Install on Archlinux

Use this PKGBUILD from AUR. It is also applicable to Manjaro.

4. Install on Slackware

Use this SlackBuild from SBO.

40

http://slackbuilds.org/repository/14.1/office/qpdfview/?search=qpdfview
https://aur.archlinux.org/packages/qpdfview/
https://en.wikipedia.org/wiki/DNF_(software)
https://en.wikipedia.org/wiki/Yellowdog_Updater,_Modified


HOW TO INSTALL UNITY TWEAK TOOL ON UBUNTU 15.04
Unity Tweak Tool is a customization tool similar with GNOME Tweak. It helps you to 
customize many things in Unity just by click. We will use it often when we customize our 
Unity later. It is available on Ubuntu official repository. If you are not using Ubuntu (Unity), 
then you will never need to install Unity Tweak.

Install from Terminal

 
sudo apt-get install unity-tweak-tool  

Install from GUI

 
Open Ubuntu Software Center > search for unity tweak > press Install. 
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BEGINNER GNOME DESKTOP CUSTOMIZATION GUIDE
After our beginner usage guide, now we bring you customization guide for GNOME. This 
article will cover basic concepts for GNOME tweaking and show you how to use GNOME 
Tweak Tool. We hope this article fills what we can't mention in our usage guide article. 
Important note for you, I write this article on GNOME 3.10.4 on Ubuntu GNOME 14.04. 
GNOME development is very fast, one feature may be deprecated as soon as new feature 
released. Enjoy!

Concepts

 
1. GNOME has important terms: GNOME Shell, Mutter, GTK.
2. GNOME is like a pie cake, consists of many layers and many components. GNOME as a 

software is not simple, it is very complex.
3. GNOME Shell is the whole interface component, anything what you see, on GNOME 

desktop. GNOME Shell is actually a component of Mutter. 
4. Mutter is a window manager, the machine of user interface, it draws your application 

windows and desktop effects. Mutter is a core machine in GNOME. Mutter makes 
GNOME Shell exist.

5. GTK (GIMP Toolkit) is a library. GNOME created from this GTK library. Sometimes, 
GTK or GTK Theme term refers to user interface components which can be changed 
by theme. This including the form of buttons, scrollbars, combobox, etc. 

6. A custom GNOME desktop usually consist of GNOME Shell theme + icon theme + GTK 
theme + window theme + cursor theme + wallpaper.

7. You must read the README file inside a downloaded theme file before installing that 
theme. Do it always for any file you download for GNOME. 

Preparation

 

  
To customize GNOME 3, you will always use GNOME Tweak. The first thing you must do is 
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open GNOME Tweak > Extensions > switch User Themes on. This will enable GNOME Tweak 
to install automatically GNOME Shell themes from file. You don't need to do it manually 
anymore. 

GNOME Control Panel
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GNOME has its own Control Panel. It is called GNOME System Settings. You can open it from 
menu. It controls anything starting from wallpaper, hardware, until user accounts.

GNOME Tweak

Beside GNOME System Settings, GNOME has one more control panel. It is GNOME Tweak. It 
is a special control panel to manage your interface such as changing GNOME theme, icons, 
fonts, and extensions. 

Change Wallpaper
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To change wallpaper in GNOME, right-click on desktop > click Wallpaper button > select one 
wallpaper available. 

Change Desktop Theme

 

In GNOME terms, desktop theme is GNOME Shell theme. To change it, open GNOME Tweak 
> Appearance > Shell Theme > select one. If you have no theme yet, download and install it 
yourself below. 

Change Icon Theme

To change icon theme, open GNOME Tweak > Appearance > Icons > select one icon theme. If 
you have no icon theme, install it as below. Above, I show you Humanity icon theme. 
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Install Desktop Theme

To install GNOME Shell theme, download it first. See 
reference below. Then open GNOME Tweak > Appearance > 
Shell theme > open the theme file (ZIP file) > OK. If GNOME 
notifies you it is installed successfully, you may activate this 
theme by selecting on its selector. For example, here I show 
you Gela theme.

Install Icon Theme

Download an icon theme first. See reference below. Extract the 
archive file (ZIP, TAR) into /home/user/.icons folder. If the .icons 
folder doesn't exist, create it. See picture above. I have 5 
different icon theme folders (Faiences) inside my .icons folder. 
Then I have Faiences options in my GNOME Tweak.

Change Color Theme

GNOME has two main colors. White and Black. To switch 
between color, open GNOME Tweak > Appearance > Global 
Dark Theme > switch it on. Then reset any opened window.
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Show Minimize & Maximize Buttons

If you are using GNOME 3 nowadays, maybe 
you feel it's annoying to have no minimize 
and maximize buttons. To show them 
permanently again, open GNOME Tweak > 
Windows > switch on for Minimize and 
Maximize. Yes, GNOME Tweak itself can't 
have minimize and maximize buttons.

End Note

GNOME desktop customization is not only these. This guide is just a basic. You can improve 
it by doing more experiences. 

Resource Reference

 
• GNOME Shell Themes: https://extensions.gnome.org 
• GNOME Shell Themes: http://gnome-look.org/?xcontentmode=191 
• GNOME Shell Themes: http://www.deviantart.com/browse/all/?

section=&global=1&q=gnome+shell  
• GNOME Icon Themes: http://gnome-look.org/index.php?xcontentmode=120x121 
• Faenza Icon Themes: http://www.deviantart.com/browse/all/?q=faenza+icon+theme 
• Wallpapers: GNOME Look
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Reference

• https://en.wikipedia.org/wiki/Mutter_%28software%29   
• https://en.wikipedia.org/wiki/GNOME   
• https://wiki.archlinux.org/index.php/GNOME   
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BEGINNER CINNAMON DESKTOP CUSTOMIZATION GUIDE
After our previous usage guide, we come with Cinnamon customization guide. This guide 
will show you how to tweak Cinnamon and tell you some of its technical concepts. You will 
learn how to change wallpaper, desktop theme, icon theme, window theme, some desktop 
effects, and Cinnamon extensions. As a bonus, you will know how to reset Cinnamon 
customization to factory settings. This is a basic guide. You will only use Cinnamon System 
Settings to do all customization. Of course you will need more improvements because 
Cinnamon has very wide range of customization. This article is based on Cinnamon 2.2.13 on 
Linux Mint 17 Qiana. Enjoy your customization!

Concepts

1. Cinnamon is basically GNOME 3. They share same concepts: GTK 3 and Mutter.
2. Mutter is GNOME 3 window manager. Cinnamon has it, but renamed it into Muffin.
3. GTK 3 is the base material where Cinnamon and GNOME 3 created from. Basically, 

any GTK 3 theme will applicable in Cinnamon too.
4. Cinnamon tweaking is centralized in Cinnamon System Settings.
5. Cinnamon has "reset to factory settings" option. So, any mistake you create may 

easily restored by this option. Cinnamon is the only one desktop to have this option.
6. Desktop layout is composition of panels, menu, and applets positioning. Cinnamon 

has more than one and may switch between them easily.
7. Cinnamon has extension, a same concept you find in Mozilla Firefox Add-ons. You 

may extend Cinnamon functionality with extensions. 

Cinnamon System Settings
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To tweak Cinnamon, you need to know Cinnamon System Settings. It is similar with KDE 
System Settings, it gives you control for the whole parts of operating system including 
Cinnamon desktop itself. By this, you control your Linux Mint (or another Linux) with point 
and click. To open it, right-click on panel > All Settings.

Change Wallpaper

To change wallpaper in Cinnamon, right-click on desktop > Change Desktop Background > 
select one picture > close.

Change Desktop Theme
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To change desktop theme, open Cinnamon System Settings > Themes > right-click one 
theme > select Apply Theme > close.

Change Window Theme

To customize window theme (its border), open Cinnamon System Settings > Themes > 
Other Settings > Window borders > select one. The default is Mint-X. But for example, I use 
AgingGorilla here. See the borders.

Change Desktop Layout

To change desktop layout, open Cinnamon System Settings > Panel > select panel layout.
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Change Icon Theme

To change icon theme, open Cinnamon System Settings > Themes > Other Settings > Icons > 
select on icons. For example, select gnome and you get default GNOME icon theme.

Tweak Desktop Effects

Cinnamon desktop effects are enabled by default. Then, you may enable many other 
effects. For example, Alt+Tab Cover Switcher. To do that, open Cinnamon System Settings > 
Window > Alt-Tab section > select one mode. Timeline mode is same with Windows Vista 3D 
Flip, coverflow mode is same with old GNOME 2 Compiz effect Coverflow.
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Enable Editing Mode

To edit panel, you must enable its editing mode first. To do 
that, right-click on panel > switch Panel Edit mode on. It is a 
unique feature on Cinnamon, and only. No other desktop has, 
except KDE (with its lock widgets) but it is also far from 
Cinnamon's one.

Add Applet

To add an applet into panel, right-click on panel > Add applets to the panel > right-click one 
applet > Add to panel. For example, I add Accessibility applet into panel. See picture beside.

Install Theme

To install a desktop theme (GTK 3), download the theme > extract it into 
/home/user/.themes > open Cinnamon System Settings > Themes > right-click newly 
installed theme > Apply Theme. For example, I download CinnXP theme and install it. See 
Nemo (bottom-right) showing .themes folder contents and System Settings (top-right) 
showing current active theme. If .themes folder doesn't exist, create it. 

Install Extension

Turn the internet connection on. Open Cinnamon System Settings > Extensions > Get more 
online > wait until all extensions loaded > select one extension > press Install > open 
Installed tab > right-click on newly installed extension > Add to Cinnamon. For example, I 
install Wobbly Windows extension. You must have internet connection to do it.

Reset To Factory Settings

To reset all changes, right-click on panel > Troubleshoot > Restore all settings to default. 
This feature is one of the most awesome thing about Cinnamon. You may reset your 
Cinnamon if you did wrong tweaking or you have broken something in Cinnamon. Another 
desktop environments have no such thing (at least, for now). 
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Resource Reference

• Official Cinnamon Themes: http://cinnamon-spices.linuxmint.com/themes 
• Cinnamon Themes (GNOME-Look): http://gnome-look.org/index.php?

xcontentmode=104 
• Cinnamon Themes (Deviantart): http://cinnamon-

shell.deviantart.com/gallery/37684652/Gtk-themes 

Reference

http://shyloh.com/themes.html
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BEGINNER MATE DESKTOP CUSTOMIZATION GUIDE
After our previous article about MATE usage guide, now we come with MATE customization 
guide. MATE is a descendant of GNOME version 2.x. MATE has what GNOME 2 has. MATE is a 
simple, widely customizable, yet user friendly desktop environment. If you want a getting 
started article to customize your MATE, this article is for you. It will cover wallpaper, theme 
installation, panel, applet, icons, and some more stuffs for your living GNOME 2, MATE. This 
article is based from MATE 1.8.2 on Ubuntu 15.04. This is our second article (after GNOME 
one) in desktop customization series.

Concepts

 
1. There are version generations: GNOME 2 and 3, GTK 2 and 3.  
2. MATE is actually GNOME 2. 
3. Technically, MATE has GNOME 2 desktop foundations: Metacity (MATE rename it 

Marco) and GTK 2. 
4. MATE has same customization workflow with GNOME 2. But it is different with 

GNOME 3. 
5. Then, if you ask for MATE desktop theme, search for GTK 2 Theme.
6. Then, if you ask for MATE window theme, search for Metacity theme.
7. Basically, any tutorial for GNOME 2 is applicable in MATE.
8. Theme installation in MATE is by opening the theme file (TAR/ZIP) or copying theme 

folder into /home/user/.themes/.
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9. Sometimes, a theme file consist of all required things (GTK 2 theme, Metacity 
theme). Sometimes, it is separated so you need to install them one by one.

10. Theme installation in MATE is same with GNOME 2. You may install a theme, combine 
it to use different window theme, use different controls theme, and then save it into 
a your own custom theme. You do it all by click with Appearance Preferences 
program.

11. Any theme installation (GTK 2, Metacity, Icon) is explained in README file in every 
theme pack. Read it before installing.

MATE Control Panel

MATE, similar with KDE, has System Settings program too. It is also similar with Windows 
Control Panel. It has management panel for MATE and the whole OS. It gives you 
comprehensive control starting from users until Software Updates. By using Control Center, 
you will do anything just by click. In Ubuntu MATE, access it from menu System > Control 
Center.

MATE Tweak

MATE desktop , just like Ubuntu OS, has both its own tweak program. It is called Mate 
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Tweak. Similar with Ubuntu Tweak but MATE's one is simpler. You can access it from MATE 
Control Center > MATE Tweak. 

Change Wallpaper

To change MATE desktop wallpaper, right-click on desktop > Change Desktop Background > 
select wallpaper > close. 

Change Desktop Theme

 

To change desktop theme, right-click desktop > Change Desktop Background > open Theme 
tab > select one theme available.
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Change Icon Theme

To change icon theme (it means change all basic icons), right-click desktop > Change 
Desktop Background > open Theme tab > press Customize > open Icons tab > select one 
icon.  

Custom A Theme 

To custom a theme, click on the top-left theme > press Customize button > 1) select control 
theme > 2) select color theme > 3) select window border > 4) select icon theme > 5) select 
cursor theme > close > press Save As. 
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Enable Desktop Effects

To enable desktop effects (compositing, including window drop shadow), open MATE Tweak 
> Windows > check Use compositing. Note: by default, you are using Marco window 
manager in MATE. You may change into Compiz window manager by selecting Compiz in 
Window manager section.

Change Default Applications

To change default application, configure a file properties in Caja file manager. For example, 
you want to associate any PNG picture with Shotwell Photo Viewer. Look for a PNG with 
Caja > right-click PNG file > Properties > Open With > select Shotwell or program you want > 
Close. 

Adding Applets
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To add a widget (applet) on MATE desktop, right-click on panel > Add to Panel > drag one 
applet from appearing window > drop that applet on panel. Useful applets you probably 
want are hardware indicator and sticky notes.  

Adding Panels

To add new panel in MATE, right-click on panel > New Panel. To delete panel, right-click > 
Delete this panel. 

Change Panel Position

To change position of a panel, right-click on panel > Properties > select position from 
Orientation selections > close. 
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Install Desktop Theme

I give you example Dust Theme. Download theme > right-click on desktop > Change 
Desktop Background > open Theme tab > press Install button > open theme file (TAR/ZIP). 

Resource Reference

• GTK 2  Themes: http://gnome-look.org/index.php?xcontentmode=100 
• Metacity Themes: http://gnome-look.org/index.php?xcontentmode=101 
• Dust Theme: https://wiki.ubuntu.com/Artwork/Incoming/DustTheme 

Reference

http://mate-desktop.org/themes 
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DISABLE UBUNTU UPDATE NOTIFICATION
For several users, it is annoying to see system update notification every day. You may 
disable it easily. Warning, update is important for security matters. You will do this with 
your own risk.

1. Open Ubuntu menu. 
2. Search for Software & Updates.
3. Open Updates tab.
4. Change into Never for Automatically check for updates entry.

This configuration will forbid the system to check any update available. So, it disables 
update notification. 
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